No Gravatar

As I’ve mentioned, I’m working from home most days. This means I’m using my MacPro, with its nice large monitor, and remoting in to my two work computers (one a local laptop, the other a remote desktop). For some reason, my Magic Mouse has lost its magic.

There’s usually some slight lag to mouse movements when you use a remote desktop program – and the slower the connection, the greater the lag. Lately, it’s becoming extremely aggravating trying to use the Bluetooth Magic Mouse with these remote sessions. I don’t know if it’s because I am using it continuously for longer periods of time than ever or if there’s some other reason, but the accuracy and lag just are terrible, even to the local laptop.

I’ve tried turning it off and on, replacing batteries, deleting from the system and re-pairing – nothing seems to help for more than a few minutes.

I have finally given up and switched to an older, corded Microsoft Mouse with a scroll wheel. The scroll wheel, even set all the way up, scrolls verrrrrrry slowwwwwwly compared the the Magic Mouse. But the pointer goes where I want and expect it to go every time.

The mouse is also much larger and heavy-feeling. But it does put the pointer where I want it to be.

Maybe there’s some other Bluetooth device interfering? Nothing else should be talking to the system, but that doesn’t mean there aren’t are devices that might be causing interference.

Any of you had this issue? If so, how did you solve it?

httpv://www.youtube.com/watch?v=394kUMWTygM

Share →